[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: problems with PCtel HSP 56 MR and PCTEL driver 0.9.4



Hello, thanks for your answer. I tried what you told me but when I load the
driver (insmod pctel, insmod ptserial) I receive the following error in
/var/log/messages, with the other hal-options:
Sep 15 13:09:49 localhost kernel: PCTel: No device detected. Abort module
loading.

When I select via686a hal option, I obtain the following:
Sep 11 23:41:49 localhost kernel: AC97 modem device found: devnum =
80008E00, devid = 1106/3068
Sep 11 23:41:49 localhost kernel: iobase_0=0xec00, iobase_1=0x0000,irq=11
Sep 11 23:41:49 localhost kernel: PCTel driver version 0.9.4 [5.05c-4.27.215
(09-14-2001)] (MR) (2002-01-31) with MANY_PORTS SHARE_IRQ SERIAL_PCI
AUDIO_ROUTING[VIA] enabled.
Sep 11 23:41:49 localhost kernel: PCTel driver built on [Linux 2.4.18-6mdk
i686 unknown "2.4.18-6mdk <132114>"] with gcc-2.96.
Sep 11 23:41:49 localhost kernel: ttyS15 at 0xec00 (irq = 11) is a PCTel

and I can dial and hear the sound of the modem, afterwards a "NO CARRIER"
message always appears. I could connect only one time.

I continue on thinking that it is a problem of the pctel-0.9.4 driver as
explained sayamindu.topcities.com/pctel.html:

"...7.6. Bugs in the pctel-0.9.4 and the 0.8.6 versions.
There is a serious bug in the drivers for the kernel 2.4x The modem often
seems to stop working/hang while dialing out, and you get nothing but a
beeeeeeeeee... sound from the modem speaker and later, the dialer gives a
message No Carrier and disconnects.
This problem has no real workaround , but sometimes unloading and reloading
of the modules work. For that the commands will be (assuming that you have
the modules in /lib/modules/'your kernel version`/misc/ )
bash$ rmmod ptserial
bash$ rmmod pctel
bash$ insmod pctel
bash$ insmod ptserial
NOTE:You must exit from your dialer before trying to unload the drivers,
otherwise you will get a device or resource busy error.
When the problems become too acute, the only solution seems to be rebooting.
It has been also noticed that sometimes, this problem is ISP dependent, with
the problem surfacing when using a particular ISP..."

I tried pctel-0.9.5 obtained from
http://perso.club-internet.fr/segfault/pctel-0.9.5.tar.gz but it happens the
same.

For the moment I tried with an external US-Robotics modem and I have no
problem.

Thanks a lot,
Francesc Companys.

P.S: The spanish country_code option for insmod ptserial is "9", my printer
had cut the page and I could not see it.


----- Original Message -----
From: Mark East <markeast@ukonline.co.uk>
To: Francesc Companys <fcompanys@lleida.org>
Sent: Friday, September 13, 2002 7:55 PM
Subject: Re: problems with PCtel HSP 56 MR and PCTEL driver 0.9.4


> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> Francesc,
> Just because Mandrake HardDrake detects your Soft Modem as VIA Tech.
VT82C686
> [Apollo Super AC97 Modem, it does NOT mean that your Modem chipset is
VIA686.
>
> The VIA Tech. VT82C686 probably refers to the AMR (Audio Modem Riser)
bridge
> chipset on your MOTHERBOARD and NOT necessarily a VIA686 chipset on your
> modem.
>
> A FAIR MAJORITY of MODERN PC's report VIA Tech. VT82C686, as this is one
of
> the commonest AMR bridge chipsets around!
>
> The AMR slot is where your softmodem is often plugged into on your
computer.
> It is direct connected to the AMR bridge chipset.
>
> Your modem COULD have another chipset such as 'sis' or 'pct789'.
>
> I therefore suggest you try the various configure chipset options and see
> which one works best.
>
> Use    ./configure  --with-hal=list   to see the various chipset options.
>
> - From what you have said, I THINK that you have PROBABLY got the 'pct789'
> chipset. So please try this option first.
>
> On Friday 13 September 2002 15:52, you wrote:
> > Hello,
> >
> > I have an ECS (EliteGroup Computer System) P4VMM2 Mainboard, it includes
a
> > PCtel HSP56 MR modem. I have a Mandrake linux 2.4.18-6mdk, it only
detects
> > a modem like "VIA technologies, VT82C686 [Apollo Super AC/97/Modem]" but
it
> > is not capable to configure it. It refers to
> > http://www.idir.net/~gromitikc/winmodem.html
> > Here I found a linux modem compatibility list, it was said that an ECS
> > PCtel AMR worked OK with pctel-0.8.9 or later. I identified the chipset
of
> > my computer as CNR v1.2, PCT303A, PCT303W, and compared it with the
model
> > in the compatibility list, I saw that both had the same chipset. I
> > downloaded pctel-0.9.4.tar.gz from "The Unofficial PCTEL modem for linux
> > site.htm" by Jan Stiffer. I unpacked it in \root\pctel-0.9.2 and
followed
> > the
> > instructions in "install.txt":
> > configure --with-hal=via686a (because the utility "HardDrake" detected a
> > modem like VT82C686, I thought it could be that).
> > I enclose the output to the commands "configure", "make", "make
install",
> > "insmod pctel", "insmod ptserial" and "tail /var/log/messages".
> >
> > The command uname -a returns the following:
> > domain 2.4.18-6mdk#1 Fri Mar 15 02:59:08 CET2002 1686 unknown.
> >
> > I added the line "alias char-major-62 ptserial" to the file
> > /etc/modules.conf to enable auto-loading of the modules pctel and
ptserial
> > as it was explained in the pctel driver FAQ. I did not know which
country
> > code I had to put in the line "options ptserial country_code=..."
because
> > the FAQ did not have the country code of Spain, so I did not add that
line.
> >
> > When I tried to connect to Internet with KPPP I receive a "NO CARRIER"
> > error, after dialling and trying to connect. I have seen something like
this
> > reported in sayamindu/topcities.com/pctel.html, "7.6. Bugs in the
> > pctel-0.9.4 and the 0.8.6 versions", but in my case I am not able to
> > connect by doing "rmmod ptserial, rmmod pctel, insmod pctel, insmod
> > ptserial". I only managed to connect the modem in the
"mini-terminal-kppp"
> > by writing "atdt973768000" (I enclose the results "prova
> > mini-terminal-kppp.doc").
> >
> > Finally, I have followed my ISP's linux instructions (I enclose them,
> > "configuracio Terra linux.mht"), but when I write pppd the modem doesn't
> > seem to do anything.
> >
> > Thanks a lot,
> >
> > Francesc Companys.
> >
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.0.7 (GNU/Linux)
>
> iD8DBQE9giaJnJBZLslFRCkRAkARAKDPF4ACnOoYkv8PCAwJAM3M/HI65QCfQm5C
> slGiFM/pcwjnvOUBxO3h4eA=
> =uNc2
> -----END PGP SIGNATURE-----
>